【Rails】Bundler 2.2.x以降は開発者が適切なプラットフォームを追加する必要がある

2021年5月24日 12:56

事象

昔作ったRailsアプリを久しぶりに修正しデプロイしようとしたところ、以下のエラーが出力されました。

# 実行コマンド
Running $HOME/.rbenv/bin/rbenv exec bundle check
# エラー内容
Your bundle only supports platforms ["x86_64-darwin-18"] but your local platform is x86_64-linux. Add the current platform to the lockfile with `bundle lock --add-platform x86_64-linux` and try again.

バンドルはプラットフォーム["x86_64-darwin-18"]のみをサポートしますが、ローカルプラットフォームはx86_64-linuxです。 `bundle lock --add-platform x86_64-linux`を使用して現在のプラットフォームをロックファイルに追加し、再試行してください。

原因

Bundlerを実行できるプラットフォームが制限されているためです。

Bundler 2.2.0がリリースされた2020年11月10日以降にRailsアプリを作成すると、Bundlerが実行できるプラットフォームはデフォルトでRailsアプリを作成した環境のOSのみとなっています。例えば、RailsアプリをmacOSで作成すると、Bundlerが実行できるプラットフォームはmacOSのみとなっているため、そのままではLinuxなどの別のOSでBundlerを実行することができません。

Gemfile.lock

# Bundler 2.2以降
# Railsアプリを作成した環境によって以下のどちらかが記述されている
PLATFORMS
  x86_64-darwin-18  # macOS
  x64-mingw32       # Windows

# Bundler 2.2未満
# PLATFORMS
#   ruby

Bundler 2.1.x以前はBundlerが実行できるプラットフォームにrubyとだけ記述されていたので、macOSで作成したRailsアプリでも何もしなくてもLinuxへデプロイできていました。

Bundler 2.2.xからは開発者がBundlerを実行する適切なプラットフォームを追加する必要があります。

インストールされているBundlerのバージョンは以下のコマンドで確認できます。

$ gem list bundler

*** LOCAL GEMS ***

bundler (default: 2.2.16, 2.1.4, 2.0.2)

対処

デプロイ先サーバーのOSをBundlerが実行できるプラットフォームに追加します。デプロイ先サーバーがLinuxの場合、以下のコマンドを実行します。

$ bundle lock --add-platform ruby
$ bundle lock --add-platform x86_64-linux

以下のようにGemfile.lockに追加されていればOKです。

Gemfile.lock

PLATFORMS
  ruby
  x86_64-darwin-18
  x86_64-linux

関連記事

【Rails】M1チップ搭載MacでRuby on Railsの開発環境構築
# はじめに M1チップ搭載MacにRuby on Railsの開発環境を構築する手順を記載します。 - MacBook Air (M1, 2020) - macOS Monterey 12.3.1 # Homebrew ## [...]
2022年5月5日 11:56
【Rails】Rakeタスクの基本情報と作成・実行方法
# はじめに Railsには標準でRakeというGemが同梱されています。RakeはRubyで実装されたMake(UNIX系のOSで使用できるコマンド)のようなビルド作業を自動化するツールです。Ruby Make、略してRakeというわけですね。 [...]
2022年3月7日 22:12
【Rails】モデルに外部キーを設定する方法とよく起こるエラー内容について
# はじめに Railsでモデルに外部キーを設定する方法について説明します。 # モデルに外部キーを設定する ## リレーションシップ 今回は1つのブログ記事は複数のコメントを持つ1対多のリレーションシップを例に説明します。現在は` [...]
2022年2月10日 14:18
【Rails】Capybaraのfill_inメソッドを実行すると「既存レコードの内容+指定した内容」がセットされる事象の原因と対処【RSpec】
# はじめに RSpec + Capybaraを使用して、Railsアプリの統合テストを実装しています。とあるモデルの編集画面において、入力フォームの内容を書き換えた上で送信し、レコードが更新されることを確認します。 入力フォームの内容を書 [...]
2022年1月27日 21:22
【Rails】GitHubのセキュリティアラートで発見された脆弱性を解消する方法
# はじめに GitHubにはセキュリティアラートという機能があります。セキュリティアラートはリポジトリに含まれるライブラリやパッケージの脆弱性を定期的にチェックし、脆弱性のあるライブラリやパッケージが発見されたらアラートで知らせてくれるという機 [...]
2022年1月16日 10:36