【Rails】bundle updateでGemがアップデートされない原因

はじめに

前回、GitHubからセキュリティアラートが届いたらすぐにGemのアップデートを行おうという記事を書きました。

しかし、Gemをアップデートしようとbundle updateを実行したのに、Gemがアップデートされないという場合があります。

今回はGemがアップデートされない原因を記述したいと思います。

Gemの依存関係が原因

Gemの依存関係とは?

Gemはそれ単体で動いているということは少なく、多かれ少なかれ別のGemと依存関係を持っていることが多いです。しかも依存関係にはバージョン指定されているのが普通です。

例えば、以下のようなGemとその依存関係があるとします。

  • GemA v1.0.0GemB v1.0.0に依存関係を持つ
  • GemA v2.0.0GemB v2.0.0に依存関係を持つ

現在インストールされているGemAは1.0.0とします。

このとき、以下のコマンドを実行してGemAのアップデートを行ったとします。

$ bundle update GemA

結果は、GemAのアップデートは行われず、1.0.0のままです。なぜならGemAが依存関係を持つGemBは1.0.0のままだからです。

BundlerはアップデートしようとしているGemの依存関係を調べ、依存関係を保つ(壊さない)ようにアップデートを行います。GemAを2.0.0にしてしまうと、GemBは1.0.0のままのため依存関係が壊れてしまうのです。

アップデートする方法

GemAをアップデートするには、同時にGemBのアップデートも行えばOKです。以下のように複数のGemの名称を指定します。

$ bundle update GemB GemA

ちなみに、すべてのGemを一気にアップデートする方法でもOKです。

$ bundle update

依存関係を調べる

Gemの依存関係を調べるには以下のコマンドを実行します。

$ gem dependency -R <Gemの名称>

個別にアップデートする場合は依存関係を調べてアップデート方針を決めていくことになるでしょう。

Gemfileのバージョン指定が原因

Gemfileのバージョン指定

Gemの設計図となるのがGemfileです。GemfileはインストールするGemのバージョンを指定することができます。

# バージョン指定なし
gem "GemA"

# バージョン指定あり
gem "GemA", "1.0.0"

# バージョン指定あり
# 1.0.0以上の最新バージョン
gem "GemA", ">= 1.0.0"

# バージョン指定あり
# 1.0.0以上1.1.0未満の最新バージョン
gem "GemA", "~> 1.0.0"

詳しくは以下の記事をご覧ください。

Gemfileでバージョン指定している場合、bundle updateを行っても指定したバージョン以上にはアップデートされません。

アップデートする方法

Gemfileのバージョン指定を書き換えてからbundle updateを行います。